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Objective
This document is intended to be used as a hand-out for training users on the Tyler Reporting Services Business Intelligence Development Solutions reporting tool. It provides step-by-step instructions on how to begin a New Project, create a Data Source, Create a Dataset, and create reports. It includes appendices on Deploying a Report, a SQL Command Reference Guide, and a Guide to Setting up Security in MUNIS so users can access information in views.
Prerequisites
Before you can successfully retrieve data for reports, you must ensure that the necessary MUNIS permissions to views and GL Restrictions are established.  If these permissions and restrictions are not set up, or not set up correctly, you may need to contact your MUNIS System Administrator or Department Manager to have them updated or added into the MUNIS system.  See Appendix C for more information.
You will also need to create a remote desktop connection to the server hosting Microsoft SQL Server Business Intelligence Development Solutions.
Knowledge of the MUNIS data dictionary is very useful. The MUNIS Data Dictionary can be found on the MUNIS Knowledgebase ( http://support.munis.com/Default.aspx?tabid=56  ).  The document is titled MUNIS Tyler Reporting Services Views Reports - Custom View Reference Manual.pdf.
Overview
The Tyler Reporting Services Business Intelligence Development Solutions architecture includes development tools, administration tools, and report viewers. There are a number of ways to get to Reporting Services programmatically, including SOAP and WMI interfaces.
The following simplified diagram of the main Reporting Services components is courtesy of http://www.accelebrate.com/sql_training/ssrs_tutorial.htm and is not intended to be an endorsement for their website.

Report Server is the core engine that drives Reporting Services. 
Report Manager is a Web-based administrative interface for Reporting Services. 
Report Designer is a developer tool for building complex reports. 
Report Builder is a simplified end-user tool for building reports. 
The Report Server database stores report definitions. Reports themselves can make use of data from many different data sources. 
Reporting Services includes two tools for creating reports: 
Report Designer can create reports of any complexity that Reporting Services supports, but requires you to understand the structure of your data and to be able to navigate the Visual Studio user interface. 
Report Builder provides a simpler user interface for creating ad hoc reports, directed primarily at business users rather than developers. Report Builder requires a developer or administrator to set up a data model before end users can create reports. 
This document describes how to use the Report Designer within Business Intelligence Development Studio. Documents can be found on the Knowledgebase explaining how to create reports using the Report Builder.
Quick Vocabulary Definitions:  Tables versus Views versus Report Models
Tables
Think of kitchen cabinets with various ingredients in each cabinet. One cabinet is for flours, another for sweeteners, another for leavening, another for spices, etc. You have the recipe and know which ingredients work together (joins and primary keys).  No security is applied at the MUNIS role level; rather through SQL Server permissions.
Views
Think of cake mix: some work is needed, but the joining of ingredients is done for you.  All MUNIS role data access restrictions apply.
Report Model
Think of a microwave dinner.  You cannot change the ingredients.  Security is applied by the fact that you cannot add fields to the model. Fields available for use in the Report Builder are only those fields defined in the Report Model for your consumption.
Report Designer
Think of a full working kitchen. Report Designer uses tables and views and offers tremendous power and flexibility to create reports.
Report Builder
Think of the microwave/fridge combo in your hotel room. The Report Builder uses Report Models and offers easy ad-hoc reporting capabilities.
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Opening Tyler Reporting Services
To open Tyler Reporting Services, select the SQL Server Business Intelligence Development Studio icon or go to Start > Programs > Microsoft SQL Server 2008> SQL Server Business Intelligence Development Studio. 
When you open the program you will see the Start Page.

[bookmark: _Toc296832870]Tip for Tyler Technology Implementation Staff
To connect to Tyler Reporting Services, go to Start > Programs > Accessories > Remote Desktop Connection.  Enter the following IP Address: 192.168.120.63 to connect to the SQL 2008 server. Enter your active directory password when prompted. This IP address uses version 7.3 on the Virtual Server. Be sure your user account has permissions as explained in the appendices to the database you select.
Once the remote desktop connection is established, go to Start > All Programs > Microsoft SQL Server 2008 > SQL Server Business Intelligence Development Studio. 
We will use a typical report request to create a report: show all vendors in a local geographic area with whom the site has conducted business.  It must include the vendor name, address, and year-to-date activity.  It should be sorted by City and then alphabetically by vendor name.
If this is the first time you have used Microsoft Sequel Server Reporting Services, you will need to create a new Project, a new Data Source and a new Dataset.  In the future, (as long as you create a shared Data Source initially), you will only need to create a Dataset for each report you write as multiple reports can be stored in the same project.  
[bookmark: _Toc296832871]Task 1: Creating a New Project

Click on Create: Project… from the Start Page
Select Business Intelligence Projects in the Project Types area of the dialog box
Select Report Server Project Wizard in the Templates area of the dialog box
Type your name as the Project Name. This project will contain all the reports you create in this class.
Click Browse to open the Project Location dialog box.
Click the Make New Folder button and enter your name again as the folder name. Click on Open and then on OK


Note: Every report you create must be stored in a project.  The project name must be a valid Windows folder name, and cannot contain …  !,@ # $ % ^ & * ( ) > < ? / | \.  A project may contain one or many reports.
Clicking OK in the New Project Dialog Box starts the Report Wizard.  A welcome screen will appear:

[bookmark: _Toc296832872]Task 2: Creating a Data Source
Click Next. The Select the Data Source page appears

Type Tyler Reporting Services for the data source name.
Select Microsoft SQL Server from the Type drop-down list, if it is not already selected.
Click Edit. The Connection Properties dialog box appears.
Select from the drop down list the name of your Microsoft SQL Server that is hosting your MUNIS database. Tyler Technology employees: if connecting to the Falmouth Office, type 192.168.120.63. 
 Click the Use Windows Authentication radio button.
Select your database name from the Select or Enter a Database Name drop-down list. The Connection Properties dialog box should now look similar to this:

Click on the Test Connection button. If the message “Test Connection succeeded” appears, click OK. If an error message appears, make sure you have the proper server name and database name entered.  If the message persists, contact your system administrator.
Click OK to return to the Select The Data Source Page
Check the Make this a shared data source check box.  A shared data source may be used by several reports in the same project or by a single report.  Shared datasources are stored separately from the reports that use them. Nonshared datasources are stored in the report definition. It is considered good practice to setup a shared datasource  so you only need to enter this connection data once.
The Data Connection string will be completed for you as shown below. The data connection string is the set of instructions for connecting to the database server where MUNIS information is stored.


Click on Next to proceed to Task 3: Create a Dataset
[bookmark: _Toc296832873]Task 3: Create a Dataset

Click on Query Builder
 

Click on Edit as Text in the upper left corner of the screen if you do not see four horizontal Tabs as shown below.

The Graphical Query Designer is divided into four horizontal Tabs:
The Diagram Tab is on top
The Criteria Tab is below the Diagram Tab
The SQL Tab is below the Criteria Tab
The Results Tab is the last section

 (
Add New Table Icon
) (
Results  Tab
) (
SQL   Tab
) (
Criteria  Tab
) (
Diagram  Tab
)
Note: MUNIS security applies to views but does not apply to tables.  See Appendix C for more information on setting security for reports built using Tyler Reporting Services.
To create a Dataset, you may either
Right Click on the Diagram Tab and select the Add Table from the Context Menu OR
Click on  the Add New Table Icon









When the Add Table Window appears, click on the View tab
Note: MUNIS security applies to views but does not apply to tables.  See Appendix C for more information on setting security for reports built using Tyler Reporting Services.


Select the ap_vendor view  and click ADD
Select the ap_invoice view and Click ADD
Close the Add Table Window by clicking on Close
Because we selected two views, ap_vendor and ap_invoice, we need to join these views.  Views are joined using the Primary Key field unique for each record .
Tyler Reporting Services makes this easy when using views by giving primary keyl fields an “a_” prefix.  In this exercise, the primary key we will use to join the tables is a_vendor_number.  
Highlight the a_vendor_number field in the ap_vendor box and drag it on top of the a_vendor_number in the ap_invoice box.


When you complete this step, a line appears between the two tables. 
Notice the SQL Tab now contains an inner join statement, joining the two views on the a_vendor_number field.  An inner join means each vendor with an invoice will appear on the report.   Vendors without invoices will not appear on the report.









To add fields to the Dataset, click on the white box Next to the field name to place a check mark in the box.  The Dataset must include any fields you would like to use in expressions, in parameters, or display on the report. To add information to the report, click on the white box Next to the field name to place a check mark in the box.  To begin, select the following fields:
From ap_vendor:
a_vendor_name
v_vend_address1
v_vend_address2
v_vend_city
v_vend_state
v_vend_zip
v_vend_status

From ap_invoice:
a_invoice_number
i_invoice_date
i_invoice_total
VERY IMPORTANT: Tyler Reporting Services views require a modification to the SELECT statement that appears in the SQL Tab.  Add the word DISTINCT to the SELECT statement as shown above to select distinct records that may otherwise appear multiple times on the report.
To see your results, you may either:
Right Click on the Diagram Tab and select Execute SQL  OR
Select the Run SQL icon that looks like an exclamation point
To sort the report alphabetically, click in the Criteria Tab Sort Type column in the vendor name row and select Ascending.  Execute or Run SQL again to see the results alphabetically. 
To limit the report to show only active vendors, click your mouse in the Filter column of the Criteria Tab in the v_vend_status row and type = A. Note that the Report Wizard will add quotation marks so do not add quotes. The value you enter is case sensitive and represents one of the following values:
A    Active Vendors
S   Stop Vendors
I   Inactive Vendors
V   Vendors added via Vendor Self Service
B   Bidding Vendors
Click on OK and then Click on Next




Select the Report Type of Tabular
[bookmark: _Toc276648471][bookmark: _Toc296832874]Task 4: Choose the Report Layout

Once you select TABULAR and click on NEXT, the Design the Table page of the Report Wizard Appears
Place v_vend_city in  the page area
Place a_vendor_name in  the group area
Place i_invoice_number in the details area
Place i_invoice_date  in the details area
Place i_invoice_total  in the details area
Tip: When using the Report Wizard, do not press the ESC key as it will exit the Wizard and return to the Start Page, without saving your work.

Click Next to move to the Table Layout Page, which appears because we placed a field in the Group area on the Design Table Page
Check the Include Subtotals check box 
Check the Enable Drilldown checkbox


Click on NEXT and Select the Generic Style in the Style List when the Choose the Table Style window appears

Click on NEXT. The Choose the Deployment Location page appears.  Accept the defaults by clicking on NEXT


On the Completing the Wizard Page, enter Vendor List as the report name

Click Finish.  The Business Intelligence Development Studio Report Designer Window appears. You will see two tabs: Design and Preview.  
 (
Report Header (not page header)
) (
Table
) (
Group
)
If you right click in the blank area between the group (v_vend_city) and the table a grey bar will surround the tablix.  A tablix provides the properties of a matrix and a table in one report item.
The tablix Is one of three report items called data regions; the other two data regions are charts and gauges. The tablix creates a textual representation of data in the dataset; the other data regions create graphical representations.
The following pictures show simple reports with a table, matrix, or list.


When you right click on the horizontal top grey bar, you may add columns or column groups to create a matrix. When you right click on the vertical side grey bar, you may add rows or row groupings to create a table. Either option allows you to view tablix properties.
 (
Output messages appear here. Use this box to see detailed explanations of errors that occur when previewing the report.
) (
Report Data. This area can be changed to a different view using Views on the top menu bar.
) (
Solution Explorer
) (
Tablix
) (
Properties of the area highlighted. In this example, the Tablix properties are displayed.
)
[bookmark: _Toc296832875]Navigating in the Design Tab


Click on the Preview tab and note that the report needs formatting. A page is printing for each city, which could result in a very long report. To change this, we need to change the group properties.  


To customize page breaks for the group or to change the sorting order of items within the group (for example, to show vendors in a specific order within the city they reside), go to the Group view.  Click on any item in the table, such as a_vendor_name, and the Group view will appear.  (
Group View
)
[bookmark: _Toc296832876]Change Page Breaks
Right click on the group row showing a_vendor_name and select Row Group >  Group Properties.  Uncheck the box labeled “Between each instance of a group”. You may need to preview the report twice to see a change in the page breaks.


[bookmark: _Toc296832877]Format Headings
The Next item noted in the preview is that it is difficult to determine the city. Let’s bold and center the city by clicking on v_vend_city and using the top menu bar icons to format the field. Do the same for the Report Title, Vendor List. 
Note: the vendor list report title is not on a page header at this time.  We will move it to a page header later in this exercise.
[bookmark: _Toc296832878]Make the columns wider
Highlight the a_vendor_name field heading so a box surrounds it. Then move your mouse into the grey area above the field heading.  Hold down the mouse pointer until a double headed arrow appears. 
Hold down the left mouse button and widen the column
Repeat this step for the remaining fields as needed.


[bookmark: _Toc296832879]Change field titles and appearance
To change the column heading, click on the heading and enter an appropriate heading such as Invoice Date.  Repeat this for all headings so your screen matches the image below:


[bookmark: _Toc276648475][bookmark: _Toc296832880]Changing the invoice date:time field to omit time
Each field may be formatted by right clicking on the field and selecting Textbox Properties.  
Click on the Report Design Tab 
Right click on the Invoice Date field
Select Textbox Properties
Select Number > Date from the list on the left, and then choose your preferred format from the list on the right.
Click on OK to close the dialog box.


Note that the General option does not control the heading. The general heading refers to the field name. It is not recommended to change this.

Notice that if you right click on a number field, such as invoice number, the Summarize By option allows you to calculate many different types of aggregate values, such as sum, avg, min, max, etc.
On your own: Format remaining fields so dollar amounts appear as currency.
[bookmark: _Toc296832881]Moving the Group Total
The Next item to change is the group total, or in our case, the total invoices by city. It appears on top of the detail records, and we would like to change this to appear at the bottom of the detail records. 
Right click in the grey vertical bar, on the bottom box, and select Insert Row > Inside Group-Below
In the new blank bottom row, click on the add field icon and select i_invoice_total. Notice that the sum formula is automatically added to the field.  Use Textbox Properties to change the alignment of the field to right justify.
[bookmark: _Toc276648473][bookmark: _Toc296832882]Using the Toolbox 
[bookmark: _Toc276648474][bookmark: _Toc296832883]Add a Report Header
Click on the Report Design Tab 
Select Report >Page Header from the top menu bar. 
A new band labeled Page Header will appear at the top of the Layout screen. Page headers appear at the top of each page.
To add text to the Page Header, you may need to view the Toolbox. To view the Toolbox, select View from the top menu bar and select Toolbox. 
Hold your mouse down on the textbox icon and drag it into the Page Header area.  
Type Vendor List into the box. Resize the box so it extends the width of the page, center text within the box, and change the font used to bold.
On your own: Add a line under the Title Text Box




[bookmark: _Toc296832884]Change group header row appearance
To change the group header row so the titles are more visible, click on the heading, such as vendor. Notice a textbox properties window appears at the bottom right side of the screen. Use this box to add a border, change colors, etc. of the heading. 
Tip: you may format several fields at once by selecting them and then using the textbox properties box to change appearance.



Tip: To draw a box around a field, select the top, left, right and bottom border styles.



[bookmark: _Toc296832885]Inserting or deleting a column
Right click in the GREY column heading area where you would like to insert a new field. You must right click in the grey area to have the option to insert columns.
Select Insert Columns to the Left or Right, whichever you prefer.
Grab a field from the left side DataSet1 and drag it into the blank column, in the field row.
Note that you can also drag a field from the DataSet1 area into the Tablix and a column will be inserted automatically.



When you click on the Preview Tab to admire your handiwork, you will notice that any vendors not assigned to a city appear without any information in the City field. To change this, we need to create a formula so the words “No City Entered” appears if a vendor has not been assigned to a city in Munis.
[bookmark: _Toc276648477]

[bookmark: _Toc276648478][bookmark: _Toc296832886]Creating Expressions (Calculated fields)

Expression Examples in Reporting Services
Some expressions are frequently used in reports. These include expressions to change the appearance of data in a report, change properties of report items, and affect how data is retrieved. For more information, see: 
http://msdn.microsoft.com/en-us/library/ms157328(SQL.90).aspx
http:://msdn.microsoft.com/en-us/library/ms345242.aspx (information in chart below is copied from this website)
[bookmark: _Toc296832887]Add a formula field

To add a formula field, Select the Design Tab and the Report Data View
Right Click on Dataset1 in the Report Data View and Select Add Calculated Field or Right Click on Dataset1 in the Report Data View and Select Dataset Properties > Fields


In the blank title area, enter a name for the calculated field. NOTE: The name may NOT contain spaces or any special characters such as , . / ? : ; “ ‘ !@#$%^&*()_+=. 
In the example below, the word City was entered. Then select the Expression box, fx.

When the Expression box appears, select Common Functions > Program Flow > Iif
When you select Iif, a pop up window explains formatting requirements

When you begin typing a recognized expression, Intellisense will let you auto-complete a phrase by double clicking on one of the choices in the drop down list. Using the categories and your mouse, create this expression:
=IIF(Trim(Fields!v_vend_city.Value)=””, "No City Found", Fields!v_vend_city.Value)
Tips for using Expressions:
All Expressions must begin with the equal sign =.
Fields! will show a list of fields in the report. To select a field, double click.
Only fields in the Dataset will appear in this list.
Even though single quotes are required in the SQL Tab WHERE clause, the expression builder requires double quotes.
The expression builder requires spaces around concatenated fields.  
Note the spaces around &  “ “ 
Intellisense will show command specifications once you type the command and the opening parenthesis, such as iif(
Mistakes made in the expression are not detected until you preview the report, although a red underline appears when mistakes are made and also appears when format is proper, for example with the DatePart expression.
You can combine more than one field by using concatenation operators. The following expression returns two fields, each on a separate line in the same text box.
	=Fields!FirstName.Value & vbCrLf & Fields!LastName.Value 
Expressions are grouped into categories as shown above. 
When you place an expression on the report, watch for the insertion of the sum command. You will need to edit the expression on the report layout tab to remove the Sum()
TIP: Do not format the expression by using the enter key to make it more readable or more visible, as enter (carriage return) is not a recognized expression.
[bookmark: _Toc296832888]To report on purchase orders over 30 days old
Use (DATEDIFF(dd, ap_purch_orders.po_prep_date, GETDATE()) > 30)

[bookmark: _Toc296832889]Using Cdec
For some fields in Tyler Reporting Service Views, the field is a datatype of decimal. When used in conjunction with other fields, an ERROR May be returned for mathematical functions.  Use the Cdec function to remove the error and return a mathematical result. For example you would like to sum this expression field
=IIF(Fields!po_total_amount.Value < 1000, Fields!po_total_amount.Value, 0)
The detail rows will appear with the proper value but the group totals will return an ERROR message unless you change this expression to:
=IIF(Cdec(Fields!po_total_amount.Value)< Cdec(1000),CDec(Fields!po_total_amount.Value),CDec( 0))
[bookmark: _Toc296832890]Using the TRIM function with concatenation
This is a useful Trim Function example if you are a long account site. We are assuming in this example that MUNIS General Ledger Parameters are set for:
•	SEGMENT 1 FUND
•	SEGMENT 2 RESOURCE
•	SEGMENT 3 GOAL
•	SEGMENT 4 FUNCTION
•	SEGMENT 5 SCHOOL
•	SEGMENT 6 PROJECT YEAR
•	SEGMENT 7 DUO
•	SEGMENT 8 NOT USED
ORDER OF ACCOUNT ENTRY
FUND – RESOURCE – GOAL – FUNCTION – SCHOOL – PROJECT YEAR – DUO – OBJECT

=TRIM(Fields!a_fund_seg1.Value) & "-" & TRIM(Fields!a_segment_2.Value) & "-" & TRIM(Fields!a_segment_3.Value) & "-" & TRIM(Fields!a_segment_4.Value) & "-" & TRIM(Fields!a_segment_5.Value) & "-" & TRIM(Fields!a_segment_6.Value)   & "-" & TRIM(Fields!a_segment_7.Value) & "-" & TRIM(Fields!a_object.Value)

[bookmark: _Toc296832891]Date Functions
Now() and Today() will display your computer’s system date on the report. To use these fields, first create a textbox and then type the expression into the Textbox. Place it in a page header or page footer.
DATEPART is very useful to separate birthdays, for example, without showing the birth year. The following chart was found at: http://www.lukehayler.com/2009/11/the-datepart-function-in-ssrs
	Expression
	Result

	DatePart(DateInterval.Second, Parameters!MyDate.Value)
	23

	DatePart(DateInterval.Minute, Parameters!MyDate.Value)
	34

	DatePart(DateInterval.Hour, Parameters!MyDate.Value)
	12

	DatePart(DateInterval.Weekday, Parameters!MyDate.Value, FirstDayOfWeek.Monday)
	5

	DatePart(DateInterval.Day, Parameters!MyDate.Value)
	13

	DatePart(DateInterval.DayOfYear, Parameters!MyDate.Value)
	317

	DatePart(DateInterval.WeekOfYear, Parameters!MyDate.Value)
	46

	DatePart(DateInterval.Month, Parameters!MyDate.Value)
	11

	DatePart(DateInterval.Quarter, Parameters!MyDate.Value)
	4

	DatePart(DateInterval.Year, Parameters!MyDate.Value)
	2009


Read more: http://www.lukehayler.com/2009/11/the-datepart-function-in-ssrs/#ixzz0vflM08ss
[bookmark: _Toc296832892]String Functions, including replacing empty fields with the text “Not Entered”
You can combine more than one field by using concatenation operators. The following expression returns two fields, each on a separate line in the same text box.
	=Fields!FirstName.Value & vbCrLf & Fields!LastName.Value 
The Right, Len, and InStr functions are useful for returning a substring, for example, trimming DOMAIN\username to just the user name. The following expression returns the part of the string to the right of a backslash (\) character from a parameter named User: 
=Right(Parameters!User.Value, Len(Parameters!User.Value) 

Cstr can be helpful if trying to convert a MUNIS number field, such as fiscal year/period (for example 201002), into a character field so you can concatenate it with dashes to display as period-year (02-2010) instead of 201002 or 

Use this formula to show the year and period 
=Right(Fields!j_jnl_year_period.Value,2) & "-" & Left(Fields!j_jnl_year_period.Value,4)

Use this expression to separate debits from credits:
=iif(Fields!j_debit_or_credit.Value="C", Fields!j_gross_amount.Value*-1,
Fields!j_gross_amount.Value*0)

Use this expression to show a debit amount as a positive number and a credit amount as a negative number:
=iif(Fields!j_debit_or_credit.Value="D", Fields!j_gross_amount.Value, Fields!j_gross_amount.Value*-1)

The following expression tests the value of a field PhoneNumber to see whether it is null and returns "Not Entered" instead of the null value. This expression can be used to control the value of a text box in a report item. 
=IIF(Trim(Fields!v_vend_city.Value)=””, "No City Found", Fields!v_vend_city.Value)

For lists longer than 3 items, the IIF statement can become cumbersome. Instead, use switch.  Here is an example for the inventory user defined field of category. User defined fields are stored in the view sp_user_data. The application id will refer to the Munis program. In our example, this is initmmst (inventory item master). The ud_data_text  field represents the user defined code.
Switch returns the first true statement evaluated. By using 1=1, (something which is always true) inventory items without a user defined field are listed as “User Defined Field not entered”.
NOTE: Switch only works with numeric fields. It does not work with character fields.

=Switch(Fields!ud_data_text.Value = 0, "All Other",
Fields!ud_data_text.Value = 1, "Dry Food",
Fields!ud_data_text.Value = 2, "Frozen", 
Fields!ud_data_text.Value = 3, "Perishable", 
Fields!ud_data_text.Value = 4, "Custodial", 
Fields!ud_data_text.Value = 3, "Health", 
Fields!ud_data_text.Value = 3, "Instructional", 
Fields!ud_data_text.Value = 3, "Information Technology", 
Fields!ud_data_text.Value = 3, "Printed Forms", 
Fields!ud_data_text.Value = 3, "Special Education",
1=1, "NoCode")

[bookmark: _Toc296832893]Page Headers and Footers
Headers and footers can contain fields, static text, images, lines, rectangles, borders, background color, and background images. 
[bookmark: _Toc296832894]Add the Page Number or the UserID to the Page Footer
Place the Textbox in the Page Footer.
Right click on the text box and select Expression 
Use =Globals!PageNumber to show the page number, or use
="Page" & Globals!PageNumber & " of " & Globals!TotalPages
Perform the same steps for UserID:
Create a textbox first
Right click on the text box and select Expression 
Use =User!UserID
Notice that the textbox will now show <<Expr>>

[bookmark: _Toc296832895]Adding the Report Title, Name, or Path to a Page Header or Footer
Use the following expressions to show the report title from a text box named ReportTitle or the report name as it is stored in the report server database with timestamp information about when the report was generated: 
[bookmark: CodeSpippet0]=ReportItems!ReportTitle.Value
=Globals.ReportName & ", dated " & Format(Globals.ExecutionTime, "d")
[bookmark: _Toc296832896]Report Headers and Footers
Page headers and footers are not the same as report headers and footers. Reports do not have a special report header or report footer area. A report header consists of the report items that are placed at the top of the report body on the report design surface. They appear only once as the first content in the report. A report footer consists of report items that are placed at the bottom of the report body. They appear only once as the last content in the report.
[bookmark: _Toc296832897]Using Headers and Footers to Position Text 
You can use headers and footers to position text on a page. For example, suppose you are creating a report that you want to mail out to vendors. You can use a header or footer to position the customer address so that it appears in an envelope window when folded.
[bookmark: _Toc296832898]Page Breaks
In some reports, you may want to place a page break at the end of a specified number of rows instead of, or in addition to, on groups or report items. To do this, create a group in a data region (typically a group immediately outside the detail), add a page break to the group, and then add a group expression to group by a specified number of rows. 
This expression, when placed in the group expression, assigns a number to each set of 25 rows. When a page break is defined for the group, this expression results in a page break every 25 rows. 
=Int((RowNumber(Nothing)-1)/25)

[bookmark: _Toc296832899]Report Print Settings
Click on the Report Designer Design Tab 
Select Report from the top menu bar
Select Report Properties
Select the Page Setup 

Note: You can also control print settings from the Design View by right clicking anywhere in the design area and selecting Page Setup




[bookmark: _Toc296832900]Adding Parameters to the Report
Tip – parameters may slow down processing time for report generation. Adding a where clause to the SQL Query is much faster but does not allow users to select options at report runtime.

As mentioned previously, the report is to show vendor activity for vendors within a user specified city. Tyler Reporting Services uses Parameters to allow users this flexibility.
Note: to use a field in a parameter, it must be included in a Dataset separate from the Dataset1 used on the report so far.
Three steps are involved in creating a report parameter:
Create a second Dataset to reference the field in the parameter query
Create a Report Parameter referencing the new dataset
Use the Criteria Tab in the Query Tab to link the appropriate field to the new parameter using =@.  This will automatically update the SQL Query where clause.


[bookmark: _Toc296832901]Step One: Create a Dataset that references the field in the parameter query

To create a Dataset, go the Report Data box and right click on the Data Source in the Report Explorer Tab.
Select Add DataSet from the Context Menu. 



Type  the information shown on the Next page into the Dataset Query tab: 
SELECT DISTINCT ap_vendor.v_vend_city FROM ap.vendor ORDER BY ap_vendor.v_vend_city 
Or copy and paste the query from  DataSet1 into DataSet2




[bookmark: _Toc296832902]Step Two: Create a Parameter that references the new dataset

Go to the Design Tab

In the Report Data Tab, Right Click on the Parameters folder

Select Add Parameter





In the Report Parameters > General Properties Window
Enter VendorCity as the Parameter Name. 
Enter Vendor City as the Prompt.
Select Text as the Data Type
Enter City as the Prompt
Check the box for Allow Blank Value
Select Visible as the Parameter visibility
Click on OK




In the Report Parameters > Available Values Window

Select Get Values From A Query in the Available Values
Select the new Dataset from the list
Select v_vend_city as the Value field 
Select v_vend_city as the Label field 
Select Non Queried in the Default Values





In the Report Parameters > Default Values Window

Select Get Values From A Query in the Available Values
Select the new Dataset from the list
Select None as the Value field 

Select OK when finished.





[bookmark: _Toc296832903]Step Three: Add a reference to the Parameter in the original dataset query

Go to the Design Tab
Right click on the original Dataset you created 
Select Query

In the Criteria Tab, find the Vendor City field in the and edit the filter to read =@VendorCity
















Select OK. 
Switch to the Preview Tab and notice the Parameter drop down box at the top of the screen. The preview will not appear until you select a city from the Parameter drop down box and then select View Report.  



Congratulations – you have completed your first report!!

[bookmark: _Toc296832904]Using Groups
Groups are useful whenever you would like to specify page breaks, create subtotals, or group information together for reporting purposes.  In the report example on the prior pages, we grouped on City using the Report Wizard. In this example, we will create a group after exiting the Report Wizard.
Click on the Tablix area so the grey identification bars are visible.
Click on the row groups icon in the bottom left corner of the Tablix.
 (
Row Group icon
)
Right Click and Select Add Group > Parent Group (since this is our first group, it is automatically the Parent; remaining groups will be child groups). Select the proper field. In our example, we will group by department and also add a group header and footer.


The Tablix will change appearance to accommodate the new group:



[bookmark: _Toc296832905]Add a page break  between groups
Right click on the row group icon and select Row Group > Group Properties.



[bookmark: _Toc296832906]Add totals to the Report
Right click on the bottom most left box in the Tablix and select Add Total.  
Note that SSRS will insert a total row for you, and automatically compute sum totals for all numeric fields. This will add a total to the report, but not to the group.

[image: ]
[bookmark: _Toc296832907]Add a total such as a count of all records on the report
Select one of the empty total columns 
Right click and select Expression
Type the following expression: =Count(Fields!a_asset_desc.Value) where (Fields!a_asset_desc.Value) represents a non numeric field that is different for each record to ensure an accurate count.
[bookmark: _Toc296832908]Add totals to the Group
Place a similar formula in the Group Footer row, in the appropriate column.
[bookmark: _Toc296832909]Change the format of the total field
Right click on the field in the Tablix
Select Placeholder Properties
Select the appropriate category, such as number, and the appropriate format, such as currency.

[image: ]
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[bookmark: _Toc296832910]Using the SSRS 2008 R2 Report Builder R3
Report Builder is a client-side application to create and design ad hoc reports that is part of Reporting Services Report Manager Tool. 
Using Report Builder users can select data and design reports without having to understand how and where the data is stored. Users can create table, matrix, or chart reports by selecting a report Design template and then dragging and dropping fields into the design area. 
The data on reports can be filtered grouped and sorted. Reports can be exported as a TIFF, PDF, Microsoft Office Excel, or HTML files. You can also interactively drill and explore data related to the content of your report. 
Report Builder has been significantly changed with version 2008 R3.  Models are no longer required; users can create their own DataSources using Tyler Reporting Services Views and Tables (item 1 below).  The original report models created by Tyler Reporting Services for Accounts Payable, Accounts Receivable and General Ledger may also be used as Datasets (which incorporate items 2 and 3 below).

Report models are preselected groups of tables and views that typically the information technology staff has created for end user reporting.  The report model is built using the Business Intelligence Development Studio (BIDS) and is comprised of 3 components within a Project:
Data Sources connect the data model to the actual data
Data Source Views draw data from the data sources
Report Models contain entities on which end users may report

Report models were required with the first version of Report Builder.  With Report Builder R3, models are no longer needed. In addition, much of the functionality of Report Designer has been added to Report Builder.
Documents on using the first version of Report Builder are available on the Munis Knowledgebase at 
http://muniskb.tylertech.com/DocumentViewer.aspx?doc=+MiWTqIueRE=&
Report Builder is part of the Report Manager Web Application that is created when SQL Reporting Services was installed.  The default location for Report Manager is:
http://ComputerName/reports
Where ComputerName is the name of the computer where Reporting Services was installed.  When you open Report Manager, you will see a screen similar to the following screen:
If you do not see the New Folder, New Data Source, Upload File and Report Builder buttons in the toolbar of the Contents Tab, you may not have content manager privileges.
[image: ]

Select Report Builder from the top menu bar to get started.  The first time you open Report Builder, you may see a message to download a program. Select Run to install the Report Builder.

[image: ]

[image: ]
 


















To create a new report using the Report Builder, highlight New Report and select the appropriate type of report, such as Table or Matrix Wizard.
To open an existing report, select Open.





















We would like to create a report showing cash balances by fund.  If the information technology staff at your site has not defined published or shared datasource(s) for your use in reporting, you will need to create a datasource for use in this report.
Select New Report > Table or Matrix Wizard. 
Select Create a Dataset.


Enter the proper information about the server as shown in the screen below where Munis information is stored for reporting purposes. This may be the actual production database server or (recommended) a report server which typically has a copy of the Munis LIVE and TRAIN databases, refreshed daily from the production database server.
Be sure to use the Test Connection button to ensure a good connection to the database has been defined.

Select Test Connection.  If you see a message other than this, contact the information technology department.
[image: ]
When the “Choose a connection to the datasource” window reappears, select Next.
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The Design a Query Window will appear.  In our example, we would like to report on cash balances by fund. To do so, we will use the gl_master_bal and the gl_detail views.  


Place a check in the box Next to each of these views.
On the right side of the screen, three boxes appear initially, a fourth appears after you run the query.
Fields
Relationships
Applied Filters
Output (appears once you select Run Query from the top toolbar.

Whenever you select more than one view, you will need to build a relationship between the views, just as we did in prior chapters using Report Designer. 
Expand the Relationships box
Click on Edit Fields so the Relationship icon is available
Click on the Add Relationship icon

 (
Relationship
Icon
) (
Expand
icon
)

[image: ]
For general ledger views, you should always join on a_org, a_object and a_project, even if your site uses long accounts and does not use org codes. Org codes are created automatically by Munis, and the combination of org, object and project fields creates a unique record identifier (primary key) for each general ledger account.

[image: ]

When finished, click on OK.
To add a filter, expand the Applied Filters box.
In our example, cash is object code 1010: Object code is 1010. If you would like the user to choose an object code when running the report, check the Parameter box.
Select Run Query when finished.
	



[image: ]

Select Next when the Query returns results as shown above to proceed to the Arrange Fields window.

In our example, we would like a row group for the cash account, a column for each fund, and a sum of the general ledger accounts in each fund with a cash account object code.
Drag the a_account_desc field into the Row Group area.
Drag the gl_master_a_fund_seg1 fields into the Column Group box.
Drag the b_cy_actual_bal into the Values box.









[image: ]
Select Next
Choose a Style. Generic is recommended for ease of formatting and viewing.
[image: ]

Select Next. The Report Builder screen will appear.
Change the Report Title to Object Code 1010 by Fund.
[image: ]

Select the Run option in the top left corner to view the report.

[image: ]
To clean up the report, select the Design icon from the top toolbar.
Format the amounts as currency by right clicking on the Sum fields in the tablix and selecting Text Expression.
Left justify column headings using the formatting toolbar.
Congratulations, you have completed a Report Builder R3 report!



[bookmark: _Toc296832911]Appendix A - Deploying Tyler Reporting Service Reports
The Report Manager Web Application is created when SQL Reporting Services was installed.  The default location for Report Manager is:
http://ComputerName/reports
ComputerName is the name of the computer where Reporting Services was installed.  When you open Report Manager, you will see a screen similar to the following screen:
[image: ]












If you do not see the New Folder, New Data Source, Upload File and Report Builder buttons in the toolbar of the Contents Tab, you may not have content manager privileges.
The Report Manager allows you to deploy reports written in Report Designer. 


Open the Report Designer 
Right Click on your Project in the Solution Explorer 
Select Properties
Go to the Deployment Area
OverwriteDataSources should be set to false for this exercise
False will copy any new data source objects but not overwrite existing data source objects. 
True will overwrite all data source objects.
In the TargetDataSourceFolder type General Ledger Project. This is the folder into which the report is going to be deployed.
Use the TargetReportFolder property to create a folder for your reports automatically
Set the TargetServerURL to the URL for your report server
Type http://ComputerName/ReportServer for the TargetServerURL, where ComputerName is the name of the computer where the Report Server is installed. 
Note: You should replace http: with https: if you are using a secure connection.
[image: ]
Click on the Report Designer Design Tab 
Select Build > Deploy (project name will appear Next to Deploy) from the top menu bar
This will publish the report to the selected folder on your report server. You can also deploy individual reports by right clicking on the report in the Solution Explorer and selecting Deploy.
Tyler Reporting Services includes a Reporting Services Configuration tool. To use this tool and deploy Tyler Reporting Services requires knowledge of Web servers, Microsoft SQL Server, and ASP.NET applications. 
For more information, go to http://msdn.microsoft.com/en-us/library/ms159868(SQL.90).aspx
[bookmark: _Toc296832912]Appendix B – SQL Reference Chart
Source: http://www.w3schools.com/SQl/default.asp
	SQL Statement
	Syntax

	AND / OR/NOT
	SELECT column_name(s)
FROM table_name
WHERE condition
AND|OR|NOT condition

Note: If multiple values are specified, use IN. Use AND if only one value

	AS (alias)
	SELECT column_name AS column_alias
FROM table_name 
or
SELECT column_name
FROM table_name  AS table_alias

	BETWEEN
	SELECT column_name(s)
FROM table_name
WHERE column_name
BETWEEN value1 AND value2

Note: Between includes starting and ending values specified
Ending value must be greater than starting value

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	DROP TABLE
	DROP TABLE table_name

	GROUP BY
	SELECT column_name, aggregate_function(column_name)
FROM table_name
WHERE column_name operator value
GROUP BY column_name

	HAVING
	SELECT column_name, aggregate_function(column_name)
FROM table_name
WHERE column_name operator value
GROUP BY column_name
HAVING aggregate_function(column_name) operator value

Whenever possible, use WHERE clause before specifying HAVING for better performance

WHERE Clause filters records individually; used on rows
HAVING filters records in the GROUP; used on groups of data

1st – WHERE
2nd – GROUP BY
3rd - HAVING

	IN
	SELECT column_name(s)
FROM table_name
WHERE column_name
IN (value1,value2,..)

Example: WHERE dbo.v_vendor_master.v_vend_state  IN (‘IN’, ‘FL’) will return all vendors located in Indiana and Florida

	
	

	INNER JOIN
	SELECT column_name(s)
FROM table_name1
INNER JOIN table_name2 
ON table_name1.column_name=table_name2.column_name

	
	SQL ISNULL(), NVL(), IFNULL() and COALESCE() Functions

Tip: Do not use = NULL because a NULL value is unknown.  Use ISNULL instead.


	LEFT JOIN
	SELECT column_name(s)
FROM table_name1
LEFT JOIN table_name2 
ON table_name1.column_name=table_name2.column_name

	RIGHT JOIN
	SELECT column_name(s)
FROM table_name1
RIGHT JOIN table_name2 
ON table_name1.column_name=table_name2.column_name

	FULL JOIN
	SELECT column_name(s)
FROM table_name1
FULL JOIN table_name2 
ON table_name1.column_name=table_name2.column_name

	LIKE
	SELECT column_name(s)
FROM table_name
WHERE column_name LIKE pattern
SELECT * FROM Persons
WHERE City LIKE 's%' 
NOTE Percentage % sign is the wildcard like * in MUNIS

	ORDER BY
	SELECT column_name(s)
FROM table_name
ORDER BY column_name [ASC|DESC]

	SELECT
	SELECT column_name(s)
FROM table_name

	SELECT *
	SELECT *
FROM table_name

	SELECT DISTINCT
	SELECT DISTINCT column_name(s)
FROM table_name

	
	

	SELECT TOP
	SELECT TOP number|percent column_name(s)
FROM table_name

	
	

	UNION
	SELECT column_name(s) FROM table_name1
UNION
SELECT column_name(s) FROM table_name2

Union will not return all records, only one, if records are identical and in both tables
Union can only be used if all fields have same data type and length in both tables.
Use UNION CORRESPONDING if tables have some fields in common but not all, specifying those common fields in the UNION CORRESPONDING statement

	UNION ALL
	SELECT column_name(s) FROM table_name1
UNION ALL
SELECT column_name(s) FROM table_name2 

Union ALL will return all records even if records are identical and in both tables

	UPDATE
	UPDATE table_name
SET column1=value, column2=value,...
WHERE some_column=some_value

	WHERE
	SELECT column_name(s)
FROM table_name
WHERE column_name operator value

	WILDCARDS
		Wildcard
	Description

	%
	A substitute for zero or more characters 

	_
	A substitute for exactly one character

	[charlist]
	Any single character in charlist

	[^charlist] 
or
[!charlist]
	Any single character not in charlist which is the list you create of values


To select the persons with a last name that starts with "b" or "s" or "p" from the "Persons" table.
We use the following SELECT statement:
	SELECT * FROM Persons
WHERE LastName LIKE '[bsp]%'





Source : http://www.w3schools.com/sql/sql_quickref.asp



[bookmark: _Toc296832913]SQL 101             
	                       


                                                 


Courtesy of Kevin Ballew,Tyler Technologies
SQL JOINS
“INNER JOIN” – Center Slice, default
“LEFT OUTER JOIN” – Left Circle AND what exists in Center Slice
“RIGHT OUTER JOIN” – Right Circle AND what exists in Center Slice – Not typically used as can flip to make left outer join instead
“FULL OUTER JOIN” – Left Circle AND Right Circle
SQL SYNTAX
“Select” – Items listed after the “Select” statement are the column names from the tables/views to be used in the report.  Example: SELECT a_employeeID.
“From” – Items listed after the “From” statement are the tables/views to be used in the report.  Example: FROM pr_employee_mast.
“Where” – Items listed after the “Where” statement are the conditions set on the columns (in the Select statement).  Example: WHERE a_employeeID = 10.
“Distinct” – To be added DIRECTLY after the select in the “Select” statement to only include unique instances of data records.  Same as Unique filter in MS Excel.



[bookmark: _Toc296832914]Appendix C – Guide to MUNIS Permissions & Restrictions needed to grant user access to information in database views

In MUNIS version 8.1 there has been a change to the view restrictions. The limit restrictions information below is no longer required if a user has permissions to see all the data. The information below may be used if you would like to restrict access to the data by specific user or role.

[bookmark: _Toc216690535][bookmark: _Toc248308450][bookmark: _Toc248308541][bookmark: _Toc248637906][bookmark: _Toc296832915][bookmark: _Toc216690536][bookmark: _Toc248308451][bookmark: _Toc248308542][bookmark: _Toc248637907]Setting Permissions 
To take advantage of MUNIS Role Based Security for reports you create, you need to use Database Views (not tables) when creating the Dataset. Database Views will activate Munis Security found in Admin => Report Writer => Tyler Reporting Services Views. The settings in this program determine what data the user can see in reports. 
Note: that these settings apply to reports created using Tyler Reporting Services Views Reports or using Business Intelligence Development Solutions.
If the Dataset is built using tables there is no security in place and the user will have access to see all data.
Tips:
The button on the Tyler Reporting Services Views screen (See screen shot #1), “Security Enabled/Disabled,” refers to “record level” security. When enabled, the security settings in ID Code Permissions for General Ledger and Payroll are used to determine access to records in MUNIS. (See the Next section for security setup requirements.)
In order to “Enable/Disable” security or to “Replace all views,” you must be logged on as a user that has permission to update the database. 
Once views are loaded or reloaded there is no need to grant permissions. All users can select data from the Database Views. It is the permissions set in the Tyler Reporting Services Views program and in ID Code Permissions that determine access to the data.
The Copy button allows you to copy “module” security defined for one user to another user. (See screen shot #2)

Procedure
Go to Admin => Report Writer => Tyler Reporting Services Views. 

Find the appropriate user.  To allow that user to access information from views relating to data stored in the module listed, check the boxes Next to that module.
Screen Shot #1[image: ]


Screen Shot #2 – Using the Copy Feature
[image: ]
[bookmark: _Toc296832916]Setting Restrictions
Note: This section applies to MUNIS versions prior to 8.3
An important distinction must be made between MUNIS security and Database View security. 
In MUNIS, users without restrictions have access to all records. 
With Database Views, users without restriction entries do not have access to any records. Because of this, permissions must be set for each user that will be using Database Views for GL and PR. 
Existing restrictions for users should be left alone. The following information applies to users who do not have any restrictions to information in payroll or general ledger, typically considered to be power users.  Please note that the restriction entries required by the Database Views are very specific and must be completed exactly as shown in the following screen shots.
[bookmark: _Toc296832917]Modifying the General Ledger Role to implement restrictions

Log onto MUNIS and go to Admin > B. Security > A. User Maintenance 
Find the appropriate role for the user that includes General Ledger.
Select Edit Role.  
[image: ]
When the role appears, click the Folder Icon Next to “Account /segment group access”.  With Database Views, users without restriction entries do not have access to any records in versions prior to version 8.1 In version 8.1, the steps below are not necessary for users with full rights to all MUNIS information.
Click the limit box and enter the following values to allow full viewing access to information in General Ledger Views:
Type		From		To
Org		0		zzzzzzzz
Object		0		zzzzz
Project		(blank)		zzzzzz
 Note:  If your site uses a period(.) or some other character to start the org or object values, replace the 0 with that character.
Then click the “Select Programs” button, and select “G/L ACCOUNT INQUIRY (glactinq)”.  Click “OK” then click “Accept”. The final result should look like this:[image: ]
Exit out of the Account /Segment Group Access screen and the General Ledger Role Maintenance screen  
[bookmark: _Toc296832918]Modifying the Payroll Role to implement restrictions
Log onto MUNIS and go to Admin > B. Security > A. User Maintenance 
Find the appropriate role for the user that includes Payroll.
Select Edit Role.  
For Payroll, four data access areas must be limited in order for a user to view all information in the payroll module: 
Deduction Maintenance, 
Location Maintenance, 
Org Maintenance, and 
Pay Type Maintenance.  

Click the limit box Deduction, Location, Org, and Pay Type Maintenance access to Limit Access which shows us that restrictions are in place for this role and enter the following values to allow full viewing access to information in the database section.
To grant full access select the folder icons Next to the Deduction Maintenance access texts, select the “Limit” button and fill in the data from the Deduction types screenshot below.  Then click accept and “OK”.  Repeat this for the Location, Org, and Pay type Maintenance access.
    


     



To grant full access select the folder icons Next to the Deduction Maintenance access texts, select the “Limit” button and fill in the data from the Deduction types screenshot below.  Then click accept and “OK”.  Repeat this for the Location, Org, and Pay type Maintenance access.
    


     


The Roles tab on the bottom will show all roles currently assigned to the user.  There may be one or many.  Click the Add button.  In the Code column, you will see a cursor and the button .  Type the name of the General Ledger role you created, or click the button and select the role from the list. Select the box below it and add the Payroll Role in the same manner. Click . The roles should now display:

To ensure that there are no conflicts with other roles for this user, go to the Data Access tab.  In the screen shot below, there are four payroll rows and one general ledger row with an access level of limited.  Be sure these rows are listed as limited for your user.  


If they are still listed as full, then double check that the Payroll and General Ledger roles created are listed as limited.  If they are, then there is a conflict with another role for this user, and that role will need to be removed, or editted with these restrictions.  Please allow your IT department or your MUNIS Lead to make the decision on how to handle this case, as editing other roles could affect numerous users, and removing roles could disable this users accesses on MUNIS .
If the five rows are list as limited, as in the screenshot, then close the UserAccount Maintenace scrreen, and you can start using the views to build reports in Tyler Reporting Services.
[bookmark: _Toc296832919]Appendix D – SQL Queries for commonly requested reports
AP Invoices with T status -  This report uses ap_invoice_proof and ap_vendor to show invoices pending 3 way match verification (status of T) grouped by AP Invoice batch, showing the clerk, the invoice number, PO number, the vendor name, invoice description, invoice date and invoice total amount, with page breaks by batch number.
SELECT DISTINCT           	ap_invoice_proof.a_invoice_number, ap_invoice_proof.i_invoice_status, ap_invoice_proof.i_batch_number, ap_invoice_proof.i_clerk,   ap_invoice_proof.a_purch_order_no, ap_invoice_proof.i_invoice_desc, ap_invoice_proof.i_inv_comments, ap_invoice_proof.i_invoice_date,                        ap_invoice_proof.i_invoice_total, ap_vendor.a_vendor_name
FROM         		ap_invoice_proof 
INNER JOIN	 	ap_vendor ON ap_invoice_proof.a_vendor_number = ap_vendor.a_vendor_number
WHERE     		(ap_invoice_proof.i_invoice_status = 'T')



Vendor Activity by City - This report uses ap_invoice and ap_vendor to show dollar totals by vendors with addresses within a user specified city.  It can be expanded to show invoice number, date and amount.

SELECT DISTINCT                      	ap_vendor.a_vendor_name, ap_vendor.v_vend_city, ap_vendor.v_vend_status, ap_invoice.a_invoice_number, ap_invoice.i_invoice_total,      ap_invoice.i_invoice_date
FROM         			ap_vendor 
INNER JOIN		              ap_invoice ON ap_vendor.a_vendor_number = ap_invoice.a_vendor_number
WHERE     			(ap_vendor.v_vend_status = 'A') AND (ap_vendor.v_vend_city = @VendorCity)
ORDER BY 			ap_vendor.v_vend_city, ap_vendor.a_vendor_name, ap_invoice.i_invoice_date

Purchase Orders Not Received - This report uses ap_purch_order, ap_vendor views and the pocomdet table to show all purchase orders using the WHERE Clause in the SQL query to retrieve any PO's with no received quantities. The report shows PO total, vendor name, PO General description, PO number and dollar amounts.

SELECT DISTINCT 	                 ap_purch_orders.a_purch_order_no, ap_vendor.a_vendor_name, ap_purch_orders.po_total_amount, pocomdet.pocd_des_sh, ap_purch_orders.pd_line_quantity,                      ap_purch_orders.pd_line_item_net, ap_purch_orders.pd_line_item_desc, ap_purch_orders.pd_recvd_quantity, ap_purch_orders.pd_canceled_quant
FROM         			ap_purch_orders
 INNER JOIN 		              ap_vendor ON ap_purch_orders.a_vendor_number = ap_vendor.a_vendor_number INNER JOIN		              pocomdet ON ap_purch_orders.po_comodity_code = pocomdet.pocd_com_cd
WHERE     			(ap_purch_orders.pd_recvd_quantity < .0001)
ORDER BY ap_purch_orders.a_purch_order_no


UnPosted Journal Entries By User Specified Source Journal - This report uses the gltrnd, gltrnh, glmaster tables to show journal entries within a user specified source journal by fund. The WHERE clause in the query determines the range of dates for entries on the report.  Multiple GL account segments are included in the SELECT clause of the query.

SELECT  DISTINCT   gljetrnd.gljd_yrpr, gljetrnd.gljd_jnl, gljetrnd.gljd_org, gljetrnd.gljd_obj, gljetrnd.gljd_project, gljetrnd.gljd_seg1, gljetrnd.gljd_segrem, gljetrnd.gljd_eff_date, gljetrnd.gljd_comm, gljetrnd.gljd_ref1, gljetrnd.gljd_dr_cr, gljetrnd.gljd_gross, glmaster.glma_desc, glmaster.glma_seg2, glmaster.glma_seg3, glmaster.glma_seg4, glmaster.glma_seg5, glmaster.glma_seg6, glmaster.glma_seg7, glmaster.glma_seg8, gljetrnh.gljh_source, gljetrnh.gljh_ent_date, gljetrnh.gljh_tran_type, gljetrnh.gljh_ref1, gljetrnh.gljh_ref3, gljetrnh.gljh_ref2, gljetrnh.gljh_ref4, gljetrnh.gljh_clerk
FROM         		gljetrnd 
INNER JOIN                glmaster ON gljetrnd.gljd_obj = glmaster.glma_obj AND gljetrnd.gljd_project = glmaster.glma_project AND gljetrnd.gljd_org = glmaster.glma_org AND gljetrnd.gljd_seg1 = glmaster.glma_seg1 
INNER JOIN                gljetrnh ON gljetrnd.gljd_yrpr = gljetrnh.gljh_yrpr AND gljetrnd.gljd_jnl = gljetrnh.gljh_jnl
WHERE     		(gljetrnh.gljh_source = @SourceJournal) AND (gljetrnh.gljh_ent_date BETWEEN '07/01/2008' AND '06/30/2009')
Posted Journal Entries By User Specified Source Journal - This report uses GL_Detail view to show journal entries within a user specified source journal. The WHERE clause in the query determines the range of dates for entries on the report.  Multiple GL account segments are included in the SELECT clause of the query.

SELECT DISTINCT 	gl_detail.a_fund_seg1, gl_detail.a_object, gl_detail.j_jnl_year_period, gl_detail.a_journal_number, gl_detail.j_clerk, gl_detail.a_project, gl_detail.a_org,                       gl_detail.j_ref4_jnl_desc, gl_detail.j_jnl_source, gl_detail.j_line_comment, gl_detail.j_debit_or_credit, gl_detail.j_auto_or_manual, gl_detail.j_gross_amount, gl_detail.j_entry_date, gl_master.a_account_desc, gl_master.a_segment_2, gl_master.a_segment_3, gl_master.a_segment_4, gl_master.a_segment_5,                       gl_master.a_segment_6, gl_master.a_segment_8, gl_master.a_account_type

FROM         		gl_detail 

INNER JOIN                gl_master ON gl_detail.a_fund_seg1 = gl_master.a_fund_seg1 AND gl_detail.a_object = gl_master.a_object AND gl_detail.a_project = gl_master.a_project

WHERE     		(gl_detail.j_jnl_source = @SourceJournal) AND (gl_detail.j_entry_date BETWEEN '07/01/2008' AND '06 / 30 / 2009 ')

ORDER BY 		gl_detail.j_jnl_source, gl_detail.a_journal_number



[bookmark: _Toc296832920]Appendix E – Payroll Reporting Example
[bookmark: _Toc296832921]Payroll Exercise – Creating a Birthday list

This exercise assumes you have setup a project and a dataset and begins when you select the Add a New Report wizard and are ready to enter the SQL Query. However, when the screen appears you will select the Add Table Icon from the top menu bar.


When the Add Table Window appears, click on the View tab
Note: MUNIS security applies to views but does not apply to tables.  See Appendix C for more information on setting security for reports built using Tyler Reporting Services.


Select the pr_employee_master view  and click ADD
Close the Add Table Window by clicking on Close
Had we selected more than one view, we would need to join these views.  Views are joined using the Primary Key field unique for each record.
[bookmark: _Toc296832922]TIPS for Payroll Reports
Always join on projection number and employee number where available
Be sure to include a projection number in the select statement (see below)
To see live data from the employee master view, be sure to specify a_projection equal to 0 (zero). To see inactive employees, specify a_projection equal to 1 (one).  To see pending actions, specify a_projection equal to 2 (two).
The field a_activity_status specifies active versus inactive versus benefits only versus pension employee status.
The field e_status is a user defined field (Personnel Status). For example, this could refer to part time or full time status.

To add fields to the Dataset, click on the white box Next to the field name to place a check mark in the box.  The Dataset must include any fields you would like to use in expressions, in parameters, or display on the report. To add information to the report, click on the white box Next to the field name to place a check mark in the box.  To begin, select the following fields:
a_projection
a_name_last
a_name_first
a_name_minit
e_activity_status
e_date_of_birth
VERY IMPORTANT: Tyler Reporting Services views require a modification to the SELECT statement that appears in the SQL Tab.  Add the word DISTINCT to the SELECT statement as shown above to select distinct records that may otherwise appear multiple times on the report.
To see your results, you may either:
Right Click on the Diagram Tab and select Execute SQL  OR
Select the Run SQL icon that looks like a exclamation point
To limit the report to show only active employees, 
Click your mouse in the Filter column of the Criteria Tab in the a_emp_status row and type = A. Note that the Report Wizard will add quotation marks so do not add quotes. The value you enter is case sensitive. Choices are:
A (Active)
P (Pension)
I (Inactive)
B (Benefits)
Click your mouse in the Filter column of the Criteria Tab in the a_projection row and type = 0 (zero) to see live payroll data.

Click on OK and then Click on Next
Select the Report Type of Tabular

Choose the Report Design
Once you select TABULAR and click on NEXT, the Design the Table page of the Report Wizard Appears
Place a_name_last in the details area
Place a_name_first in the details area
Place a_name_minit in the details area
Place e_date_of_birth in the details area



Click on NEXT and Select the Generic Style in the Style List when the Choose the Table Style window appears.  

Click on NEXT. The Choose the Deployment Location page may appear; if so, accept the defaults by clicking on NEXT
On the Completing the Wizard Page, enter Birthday List as the report name

Click Finish.  The Business Intelligence Development Studio Report Designer Window appears. You will see two tabs: Design and Preview.  You should be on the Design Tab.  
Click on the Preview tab and note that the report needs formatting. Return to the Design tab to format the column widths.
To see the tablix column and row property bars, click on the a field in the columns
Now the tablix should be surrounded by a grey border.
You can widen columns by stretching the top grey border above the column

Highlight the a__name_last field heading so a box surrounds it. Then move your mouse into the grey area above the field heading.  Hold down the mouse pointer until a double headed arrow appears. 
Hold down the left mouse button and widen the column
Repeat this step for the remaining fields as needed
Click  on the top line to make the page title bold and centered
Double click on the a_name_last field heading and type the words Last Name to replace the heading 
Double click on the e_birth_date field heading and type the words Birth Date to replace the heading 
Repeat to change the headings for the remaining fields 


[bookmark: _Toc296832923]Format the birth date to show only birth month and day:
You will need to add fields for the birth month name, the birth month number and the birth day number. To do so, right click on the Dataset in the Left side Report Data area and select Add Calculated Fied

When the Fields box appears,
Enter BirthMonthName (no spaces) in the first empty field  name row and then select the Expression icon Fx

For the Expression, Enter
 =MonthName(Month(Fields!e_date_of_birth.Value)) 
Select OK
Repeat these steps for the BirthDay using this expression:
Name the Expression BirthDay
For the Expression, Enter
=Day(Fields!e_date_of_birth.Value)
Drag these fields into the report once created
TIP: Be sure to occasionally save your report by clicking on the Diskette icon on the top menu bar or selecting File > Save

Optionally Center and Rename the columns
[bookmark: _Toc296832924]Create a name field
Insert a column to the right of the middle initial field by right clicking in the grey body bar above the middle initial field
Enter Name as the heading in the box directly below the body bar
Right click on the third row empty box and select Expression
Use the Common Functions > Text > Trim and the Fields options to create the expression below, or you may type it exactly as appears below:
=TRIM(Fields!a_name_last.Value)+", "+TRIM(Fields!a_name_first.Value)+" +Fields!a_name_minit.Value
Click OK
Delete the columns containing the last name, first name and middle initial. Tip: hold the shift key as you highlight the grey body bar above these columns. Right click and select Delete Columns to delete the three columns at once.


The design tab will  now show <Expr> rather than the field names in the tablix:














[bookmark: _Toc296832925]Adding a page header
Right click in the small grey box in the left corner of the Body bar and select “Add Page Header”
Move the title to the page header
Right click on the title and select Properties
Select the Font tab and change the font to 14 point, bold
Select ok
Center the title by highlighting it and clicking on the center icon on the top menu bar

[bookmark: _Toc296832926]Adding A Group
Right click on the tablix box to see row group property icon. When you right click on the row group icon and select “Add Group” and since this is our first group, select Parent Group.


Select Group By and the Expression Fx icon
Enter the expression as shown on the Next page. When complete, check the add group header and footer options as shown below.


The group expression appears below:




[bookmark: _Toc296832927]Change the Sort Order to sort by birth month then birth day
You will need to modify the SELECT Statement to add fields for the birth month name, the  birth month number and the birth day number as shown below:
SELECT DISTINCT                       a_projection, a_name_last, a_name_first, a_name_minit, e_activity_status, e_date_of_birth, DATEPART(mm, e_date_of_birth) AS MonthNumber, DATEPART(dd,                      e_date_of_birth) AS DayNumber
FROM         pr_employee_mast
WHERE     (e_activity_status = 'A') AND (a_projection = 0) 

While you have the query builder open, also sort the report alphabetically.  To sort the report alphabetically:
Click in the Criteria Tab Sort Type column in the MonthNumber row and select Ascending, order 1.  
Click in the Criteria Tab Sort Type column in the DayNumber row and select Ascending, order 2.  
Click in the Criteria Tab Sort Type column in the a_name_last row and select Ascending, order 3  
Click in the Criteria Tab Sort Type column in the a_name_first row and select Ascending, order 4. 
CONGRATULATIONS! You have completed a payroll report!!
[bookmark: _Toc205008952][bookmark: _Toc205016387][bookmark: _Toc216690499][bookmark: _Toc248308429][bookmark: _Toc248308504][bookmark: _Toc282074919][bookmark: _Toc296832928]Tips for one time pay vendor records

The one time pay vendor is setup in Munis with a status of “one time”. When invoices are entered using this type of vendor, a pop up window appears allowing the user to enter the vendor name and address. This is a convenient way to issue payments without setting up individual vendor files when a Form 1099 is not needed and it is not anticipated that the vendor will be used on a regular basis.
The one time vendor does present a reporting challenge, as the vendor name on reports when using the ap_Checks view or the ap_vendor view shows as the name entered in the main vendor record, typically “ONE TIME VENDOR”
To show the vendor name that the user entered on the pop up window, 5 steps are needed. 
Add  the ap_invoice_remit view to the report

Link the ap_vendor view to the ap_invoice_remit view using a left outer join. To do this, right click on the lines between the two views in the Dataset view:
[image: ]
Add the invoice_remit ir_name field to the report



Create a formula for the vendor name that is comprised of the following:
=IIf(Fields!a_vendor_name.Value = "ONE TIME PAY", 
Fields!ir_name.Value,
Fields!a_vendor_name.Value)

Note that the "ONE TIME PAY" shown above must match the name entered for the master one time pay vendor record, not the name entered by the user when the pop up window appears in AP invoice entry.

Insert the formula on the report where the vendor name should appear
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